Can not reach Tech Support

I am paying for premium support but cannot even get the bot open. No way to ask questions, chat, or leave a text message. Clearly the system continues to be overwhelmed. I want to cancel my subscription but cannot contact the company even for that. Anyone know how to get a message through?

Hi Dr. McCormick, you should be able to reach support by clicking on the “HELP” button from the bottom of your page.

Give that a try. But I’ll also notify the team of your request in the meantime.

Thank you so very much for the response. I have been trying to contact Doxy.me literally for 3 weeks.

Yes, I know about the help button, the bot support, the chat support, the phone support. I have used those in the past. But here is the concern: Usually the “HELP” button does nothing when I click it. Rarely it will open a window that looks like it may be the bot support window but there are no fields, not text, “no nuthin’” in the window. Just an open frame. I suspect the system is just overwhelmed, but I have tried the HELP button on off hours (late Sundays, early mornings, etc.) with the same results. I am not a guy who abuses tech support but the total unavailability of any contact whatsoever simply won’t do. PLEASE help me find out how to at least “talk” to the bot, or else help me find out how to cancel my annual enrollment.

Thank you,

Dr. Bruce McCormick

Hi Bruce! I’m not a doxy employee but something you might try is using an “incognito” window in your browser or try another browse altogether. The help function should work regardless of its use by others. To me it sounds like a browser or pop up blocker that not letting you get anywhere. Hope this helps!

hi, I am not sure how this community operates in terms of asking questions.
I have an issue - I am having trouble with the invite button . It will not send the invitation. "
It is not anything to do with the mouse bar on my computer because I can use the bar to move to messages and the account setup etc. Is anyone able to help? I have turned off the computer, closed the doxy site down. and it still does not work. Any help available? I tried calling tech but it went to recording. I left a message and have not heard back. I pay to use Doxy.me.