Compatibility with Apple M1

Is doxy.me compatible with Apple’s new M1?