Discontinuation of iOS App


#1

Starting Jan 1, we will no longer support the iOS app. To have a Doxy.me call on an iPhone/iPad, use Safari 11+.

Learn more


#2

What generation iPhone will support Safari 11+?


#3

The iPhone 5s and later will support Safari 11+. Here is a list of supported devices: https://www.techradar.com/news/ios-11-compatibility-list-does-it-work-with-your-iphone-and-ipad