Doxy.me product update: Fix to an AirPods connection bug, and a new filter for clinic admins

Hi, doxy.me community! This release includes a fix to an AirPods connection bug, and a new Meeting History and Usage filter for clinic admins.

As of Wednesday, June 30th, the following updates were made to the platform:

User Experience Improvements

  • Fixed a bug where in isolated incidents AirPods were not connecting properly.
  • Clinic admins and owners can now use a new Analytics filter on the Meeting History and Usage pages to view the activity information of a specific provider, or of a personal or shared room.

This release also includes many behind-the-scenes security enhancements and performance improvements.

Be sure to check out previous updates if you missed them. And subscribe to our product updates forum by clicking on the bell icon in the right-hand margin to be notified anytime we post news here!

So I have been having problems with my patients not being able to hear me with my air pods and then any other microphone .Pass the pre call test with everything working. They work on Zoom and everything else. Just not in Doxy.me

I had the issue with my AirPods not connecting again today so not sure the bug fix, fixed the bug. When they don’t work, we then have to hang up and reconnect in order for the client to be able to hear me.

@colleenconrad @blaketherapy Thanks we’ll look into this. Sorry for the hassle!

Noted! Thank you for commenting and letting us know. My team and I are looking into this.

I assume this will also fix the bug at the patient’s end too? I don’t use AirPods but had noticed that they failed frequently when the patients were using them.

I don’t wear buds but many of my pts do so I must assume some issues with connection are because of the ear buds they are wearing?

@colleenconrad @blaketherapy To clarify, the issue that was fixed was that occasionally AirPods were not being displayed at all in the call settings. They should now appear. If the AirPods are connected to your device before the doxy.me call then it should work. However, we did find a bug when trying to connect AirPods while on an active call, we are currently working on a fix for this as well. If they still are not working as expected please let me know and we will investigate this issue as soon as possible. Thanks for your patience.

@142857 Yes, if the patients are connected before the call starts then they should find the AirPods option in the settings.

@victoriaehmen Can you please describe in more detail what connection issues you are experiencing?

It’s often been the case that when patients connect with the Bluetooth earbuds on that they have to disable them before they can talk to me. I assume whatever the problem is here that it has been fixed. Reloading the web page at one or both ends did not fix this until the earbuds were disabled. I haven’t noticed this problem recently and don’t know whether that means it’s fixed vs. patients have learned not to use earbuds when they talk to me