Keyboard clicking during session

I have been using Doxy a lot for a couple of months now. With one client, when we talk it sounds like a keyboard is clicking in the background when I talk. The client is also able to hear the sound. My client thought she could hear a voice in the background as well. We ended up switching over to our phone to talk because the sound is distracting and it feels like there is interference with the call. Does anyone have any idea as to why this is happening? I only have an issue when I conduct sessions with this client.

Thank you!

I have had the same experience.
We are becoming uncomfortable that sessions are no longer private and encrypted.

Same experience here, happens with multiple clients, usually a few minutes in to the session. Only happens when one of us talking, sounds like someone typing the background. No voices, but does seem like someone is eavesdropping. Any resolution to this Doxy.me?

Hi There,

The issue of hearing this clicking sound may be directly related to an elevated Latency (packet loss) where regardless of a great download and upload speed, you may have packet loss due to network congestion and one of the results is a clicking sound, others get an echo or robotic voice bc the audio sound is missing packets of info and gives off those weird sounds (it also could be someone physically typing and the mic is very close to the keyboard, but thats probably not the case). Can you or the patient test your network speeds here, would like to see latency under 100 ms, even better under 50ms and as close to 1 as possible. Speed Test by Measurement Lab

this article offers some tips to reduce packet loss:
How to Reduce Packet Loss

Wondering how to reduce packet loss? Before we get into options for a packet loss fix, it’s worth it to say there’s no way to completely stop packet loss. Zero percent packet loss is unachievable because the things causing it, like network issues, too many users, or an overloaded system, are bound to pop up. Any solutions recommended here or elsewhere are ways to help fix the problem after the fact, not prevent them from occurring.

But there are some tried-and-true methods you can try on your own to fix high packet loss.

  1. Check your connections: First, get rid of the obvious options. Make sure your cables and ports are plugged incorrectly.
  2. Restart your system: If you haven’t turned off your system routers or hardware in a while, now is the time. This might give your network the jumpstart it needs to fix any tiny glitches or bugs.
  3. Try cable connections instead of Wi-Fi : Since everything is connected by Wi-Fi nowadays, packets are more likely to get lost. Using an Ethernet connection instead of Wi-Fi can help move things along. A fiber-optic connection is even better.
  4. Remove anything capable of causing static: Cut off surrounding cameras, devices using Bluetooth, wireless speakers, and headphones. You also might want to temporarily shut down your firewall since it uses a lot of bandwidth, and you shouldn’t be running more than one firewall program at a time.
  5. Update your software: It’s time to stop putting off your software updates. An up-to-date operating system is less likely to have bugs, which inevitably leads to fewer opportunities for packet loss.
  6. Replace out-of-date hardware: The same concept applies to your network infrastructure. Take some time to make sure your hardware is in good shape.
  7. Use QoS settings: Quality of Service (QoS) settings help you manage packet loss by triaging your network resources accordingly. This is especially important if your network transmits resource-intensive data like streamed content, online games, video calls, or VoIP. QoS settings will devote more network traffic to the places that need it.

Yesterday I had to terminate a session on Doxy because the clicking sound of someone else, not me or client was so loud and distracting. We both restarted and it continued. Had to switch to FaceTime with which there were no problems. I am not impressed with sound issues still going on.

Next I get feedback. I am 3 feet away from router as are clients. I put on headphones, and still there is an echo. It really ruins the session. Facetime and telephone have been better recently. Why are these sound problems not fixed?

Speed checked, is extra fast. Software is totally up to date. Not even year old computer. No one else on internet at home either place.

Thank you for the explanation. I am not qualified to determine if that is the cause for the clicking/crackling sound.
We don’t run into it very often, certainly less than 10% of the time, maybe closer to 5%. But when we do encounter it, we can’t continue the session, it is too distracting.

If your explanation is true, can you explain why plugging in wired earbuds immediately fixes the problem?

Perhaps the noise cancelling processing is done upstream (not on the patient’s device), so a low latency prevents the speaker noise from getting effectively cancelled by the cloud? And when headphones are worn, there is no longer any speaker noise to get cancelled. If this is the explanation, then headphones don’t “fix” the problem (speaker sound is not cancelled properly), they just prevent the microphone from hearing the speakers (noise canceling isn’t needed).

Perhaps this is why Facetime doesn’t have this issue. The app likely has noise cancelling built into it, not dependent on Apple cloud servers to do the work for it. So, even when low latency is encountered, the noise canceling still functions.

Because Doxy.me is not a standalone app (which is one of the reasons why we love Doxy.me), it misses out on some of the advantages that an app would provide. But not needing an app is one of Doxy.me’s great advantages.

It seems that some other teleconferencing platforms have this figured out though. Perhaps in low latency situations, Doxy.me could revert to “half duplex”, where only one audio stream is carried at a time (if I am speaking, no one else’s microphone is active). Old conference room phones used to work this way (and no one liked them). But “full duplex” (everyone can speak simultaneously) is a noise cancelling challenge. Or perhaps additional lag on the audio could be added. This can make for a frustrating conversation, but a frustrating conversation might be better than abandoning the session.

I am not qualified to be diagnosing the problem, nor should I be proposing solutions. But I hope that qualified people are working on it.