Screen sharing on Chrome

I think at one point I denied Chrome permission so that I can screen share but I need to undo it because right now I can’t screen share when I am using Chrome. I’ve tried resetting my permissions, deleting cookies, etc. but I can’t find out where to allow doxy.me access to my screen using Chrome. I can do it using Safari but Chrome says I need to allow access but I don’t know where to find how to do that. Thank you!

1 Like

Please direct us to the options we have for the screen sharing feature with the Chrome browser. I committed to the Doxy service by upgrading to a paid plan with the goal of using all the features - screen sharing, file sharing, etc. Unfortunately, the screen sharing feature has not been accessible. I have to use the Firefox browser for screen sharing. I attempted all the suggestions I found in the doxy support to enable screen sharing with no success.